Skip to content

leaf2

Table of Contents

Management

Management Interfaces

Management Interfaces Summary

IPv4

Management Interface description Type VRF IP Address Gateway
Management0 oob_management oob default 192.168.0.13/24 192.168.0.1

IPv6

Management Interface description Type VRF IPv6 Address IPv6 Gateway
Management0 oob_management oob default - -

Management Interfaces Device Configuration

!
interface Management0
   description oob_management
   no shutdown
   ip address 192.168.0.13/24

Name Servers

Name Servers Summary

Name Server Source VRF
1.1.1.1 default
8.8.8.8 default

Name Servers Device Configuration

ip name-server vrf default 1.1.1.1
ip name-server vrf default 8.8.8.8

NTP

NTP Summary

NTP Local Interface

Interface VRF
Management0 default

NTP Servers

Server VRF Preferred Burst iBurst Version Min Poll Max Poll Local-interface Key
time.google.com default - - - - - - - -

NTP Device Configuration

!
ntp local-interface Management0
ntp server time.google.com

Management API HTTP

Management API HTTP Summary

HTTP HTTPS Default Services
False True -

Management API VRF Access

VRF Name IPv4 ACL IPv6 ACL
default - -

Management API HTTP Configuration

!
management api http-commands
   protocol https
   no shutdown
   !
   vrf default
      no shutdown

Authentication

Local Users

Local Users Summary

User Privilege Role
admin 15 network-admin

Local Users Device Configuration

!
username admin privilege 15 role network-admin secret sha512 $6$aKHHd57oXIFPAR8b$P279AwBfC9wE/ZMi5FJZXTrRmM5CUYUFvd7wS9zkBonZAq7qvhZTXumjA0BgWy8RS./3/iGqx4lPXR5kv4Y64.

Monitoring

Spanning Tree

Spanning Tree Summary

STP mode: mstp

MSTP Instance and Priority

Instance Priority
0 16384

Spanning Tree Device Configuration

!
spanning-tree mode mstp
spanning-tree mst 0 priority 16384

Internal VLAN Allocation Policy

Internal VLAN Allocation Policy Summary

Policy Allocation Range Beginning Range Ending
ascending 1006 1199

Internal VLAN Allocation Policy Configuration

!
vlan internal order ascending range 1006 1199

VLANs

VLANs Summary

VLAN ID Name Trunk Groups
110 Tenant_A_OP_Zone_1 -
160 Tenant_A_VMOTION -

VLANs Device Configuration

!
vlan 110
   name Tenant_A_OP_Zone_1
!
vlan 160
   name Tenant_A_VMOTION

Interfaces

Ethernet Interfaces

Ethernet Interfaces Summary

L2

Interface Description Mode VLANs Native VLAN Trunk Group Channel-Group

*Inherited from Port-Channel Interface

IPv4

Interface Description Type Channel Group IP Address VRF MTU Shutdown ACL In ACL Out
Ethernet1 P2P_LINK_TO_SPINE1_Ethernet2 routed - 172.30.255.3/31 default 1500 false - -

Ethernet Interfaces Device Configuration

!
interface Ethernet1
   description P2P_LINK_TO_SPINE1_Ethernet2
   no shutdown
   mtu 1500
   no switchport
   ip address 172.30.255.3/31

Loopback Interfaces

Loopback Interfaces Summary

IPv4

Interface Description VRF IP Address
Loopback0 EVPN_Overlay_Peering default 192.0.255.4/32
Loopback1 VTEP_VXLAN_Tunnel_Source default 192.0.254.4/32
Loopback100 Tenant_A_OP_Zone_VTEP_DIAGNOSTICS Tenant_A_OP_Zone 10.255.1.4/32

IPv6

Interface Description VRF IPv6 Address
Loopback0 EVPN_Overlay_Peering default -
Loopback1 VTEP_VXLAN_Tunnel_Source default -
Loopback100 Tenant_A_OP_Zone_VTEP_DIAGNOSTICS Tenant_A_OP_Zone -

Loopback Interfaces Device Configuration

!
interface Loopback0
   description EVPN_Overlay_Peering
   no shutdown
   ip address 192.0.255.4/32
!
interface Loopback1
   description VTEP_VXLAN_Tunnel_Source
   no shutdown
   ip address 192.0.254.4/32
!
interface Loopback100
   description Tenant_A_OP_Zone_VTEP_DIAGNOSTICS
   no shutdown
   vrf Tenant_A_OP_Zone
   ip address 10.255.1.4/32

VLAN Interfaces

VLAN Interfaces Summary

Interface Description VRF MTU Shutdown
Vlan110 Tenant_A_OP_Zone_1 Tenant_A_OP_Zone - false

IPv4

Interface VRF IP Address IP Address Virtual IP Router Virtual Address VRRP ACL In ACL Out
Vlan110 Tenant_A_OP_Zone - 10.1.10.1/24 - - - -

VLAN Interfaces Device Configuration

!
interface Vlan110
   description Tenant_A_OP_Zone_1
   no shutdown
   vrf Tenant_A_OP_Zone
   ip address virtual 10.1.10.1/24

VXLAN Interface

VXLAN Interface Summary

Setting Value
Source Interface Loopback1
UDP port 4789

VLAN to VNI, Flood List and Multicast Group Mappings

VLAN VNI Flood List Multicast Group
110 10110 - -
160 55160 - -

VRF to VNI and Multicast Group Mappings

VRF VNI Multicast Group
Tenant_A_OP_Zone 10 -

VXLAN Interface Device Configuration

!
interface Vxlan1
   description leaf2_VTEP
   vxlan source-interface Loopback1
   vxlan udp-port 4789
   vxlan vlan 110 vni 10110
   vxlan vlan 160 vni 55160
   vxlan vrf Tenant_A_OP_Zone vni 10

Routing

Service Routing Protocols Model

Multi agent routing protocol model enabled

!
service routing protocols model multi-agent

Virtual Router MAC Address

Virtual Router MAC Address Summary

Virtual Router MAC Address: 00:1c:73:00:dc:01

Virtual Router MAC Address Configuration

!
ip virtual-router mac-address 00:1c:73:00:dc:01

IP Routing

IP Routing Summary

VRF Routing Enabled
default true
default false
Tenant_A_OP_Zone true

IP Routing Device Configuration

!
ip routing
ip routing vrf Tenant_A_OP_Zone

IPv6 Routing

IPv6 Routing Summary

VRF Routing Enabled
default false
default false
Tenant_A_OP_Zone false

Static Routes

Static Routes Summary

VRF Destination Prefix Next Hop IP Exit interface Administrative Distance Tag Route Name Metric
default 0.0.0.0/0 192.168.0.1 - 1 - - -

Static Routes Device Configuration

!
ip route 0.0.0.0/0 192.168.0.1

Router BGP

Router BGP Summary

BGP AS Router ID
65102 192.0.255.4
BGP Tuning
no bgp default ipv4-unicast
distance bgp 20 200 200
graceful-restart restart-time 300
graceful-restart
maximum-paths 4 ecmp 4

Router BGP Peer Groups

EVPN-OVERLAY-PEERS

Settings Value
Address Family evpn
Source Loopback0
BFD True
Ebgp multihop 3
Send community all
Maximum routes 0 (no limit)

IPv4-UNDERLAY-PEERS

Settings Value
Address Family ipv4
Send community all
Maximum routes 12000

BGP Neighbors

Neighbor Remote AS VRF Shutdown Send-community Maximum-routes Allowas-in BFD RIB Pre-Policy Retain
172.30.255.2 65001 default - Inherited from peer group IPv4-UNDERLAY-PEERS Inherited from peer group IPv4-UNDERLAY-PEERS - - -
192.0.255.1 65001 default - Inherited from peer group EVPN-OVERLAY-PEERS Inherited from peer group EVPN-OVERLAY-PEERS - Inherited from peer group EVPN-OVERLAY-PEERS -

Router BGP EVPN Address Family

EVPN Peer Groups

Peer Group Activate
EVPN-OVERLAY-PEERS True

Router BGP VLAN Aware Bundles

VLAN Aware Bundle Route-Distinguisher Both Route-Target Import Route Target Export Route-Target Redistribute VLANs
Tenant_A_OP_Zone 192.0.255.4:10 10:10 - - learned 110
Tenant_A_VMOTION 192.0.255.4:55160 55160:55160 - - learned 160

Router BGP VRFs

VRF Route-Distinguisher Redistribute
Tenant_A_OP_Zone 192.0.255.4:10 connected

Router BGP Device Configuration

!
router bgp 65102
   router-id 192.0.255.4
   no bgp default ipv4-unicast
   distance bgp 20 200 200
   graceful-restart restart-time 300
   graceful-restart
   maximum-paths 4 ecmp 4
   neighbor EVPN-OVERLAY-PEERS peer group
   neighbor EVPN-OVERLAY-PEERS update-source Loopback0
   neighbor EVPN-OVERLAY-PEERS bfd
   neighbor EVPN-OVERLAY-PEERS ebgp-multihop 3
   neighbor EVPN-OVERLAY-PEERS password 7 q+VNViP5i4rVjW1cxFv2wA==
   neighbor EVPN-OVERLAY-PEERS send-community
   neighbor EVPN-OVERLAY-PEERS maximum-routes 0
   neighbor IPv4-UNDERLAY-PEERS peer group
   neighbor IPv4-UNDERLAY-PEERS password 7 AQQvKeimxJu+uGQ/yYvv9w==
   neighbor IPv4-UNDERLAY-PEERS send-community
   neighbor IPv4-UNDERLAY-PEERS maximum-routes 12000
   neighbor 172.30.255.2 peer group IPv4-UNDERLAY-PEERS
   neighbor 172.30.255.2 remote-as 65001
   neighbor 172.30.255.2 description spine1_Ethernet2
   neighbor 192.0.255.1 peer group EVPN-OVERLAY-PEERS
   neighbor 192.0.255.1 remote-as 65001
   neighbor 192.0.255.1 description spine1
   redistribute connected route-map RM-CONN-2-BGP
   !
   vlan-aware-bundle Tenant_A_OP_Zone
      rd 192.0.255.4:10
      route-target both 10:10
      redistribute learned
      vlan 110
   !
   vlan-aware-bundle Tenant_A_VMOTION
      rd 192.0.255.4:55160
      route-target both 55160:55160
      redistribute learned
      vlan 160
   !
   address-family evpn
      neighbor EVPN-OVERLAY-PEERS activate
   !
   address-family ipv4
      no neighbor EVPN-OVERLAY-PEERS activate
      neighbor IPv4-UNDERLAY-PEERS activate
   !
   vrf Tenant_A_OP_Zone
      rd 192.0.255.4:10
      route-target import evpn 10:10
      route-target export evpn 10:10
      router-id 192.0.255.4
      redistribute connected

BFD

Router BFD

Router BFD Multihop Summary

Interval Minimum RX Multiplier
1200 1200 3

Router BFD Device Configuration

!
router bfd
   multihop interval 1200 min-rx 1200 multiplier 3

Multicast

IP IGMP Snooping

IP IGMP Snooping Summary

IGMP Snooping Fast Leave Interface Restart Query Proxy Restart Query Interval Robustness Variable
Enabled - - - - -

IP IGMP Snooping Device Configuration

Filters

Prefix-lists

Prefix-lists Summary

PL-LOOPBACKS-EVPN-OVERLAY

Sequence Action
10 permit 192.0.255.0/24 eq 32
20 permit 192.0.254.0/24 eq 32

Prefix-lists Device Configuration

!
ip prefix-list PL-LOOPBACKS-EVPN-OVERLAY
   seq 10 permit 192.0.255.0/24 eq 32
   seq 20 permit 192.0.254.0/24 eq 32

Route-maps

Route-maps Summary

RM-CONN-2-BGP

Sequence Type Match and/or Set
10 permit match ip address prefix-list PL-LOOPBACKS-EVPN-OVERLAY

Route-maps Device Configuration

!
route-map RM-CONN-2-BGP permit 10
   match ip address prefix-list PL-LOOPBACKS-EVPN-OVERLAY

ACL

VRF Instances

VRF Instances Summary

VRF Name IP Routing
default disabled
Tenant_A_OP_Zone enabled

VRF Instances Device Configuration

!
vrf instance Tenant_A_OP_Zone

Virtual Source NAT

Virtual Source NAT Summary

Source NAT VRF Source NAT IP Address
Tenant_A_OP_Zone 10.255.1.4

Virtual Source NAT Configuration

!
ip address virtual source-nat vrf Tenant_A_OP_Zone address 10.255.1.4

Quality Of Service