Skip to content

spine1

Table of Contents

Management

Management Interfaces

Management Interfaces Summary

IPv4

Management Interface description Type VRF IP Address Gateway
Management0 oob_management oob default 192.168.0.10/24 192.168.0.1

IPv6

Management Interface description Type VRF IPv6 Address IPv6 Gateway
Management0 oob_management oob default - -

Management Interfaces Device Configuration

!
interface Management0
   description oob_management
   no shutdown
   ip address 192.168.0.10/24

Name Servers

Name Servers Summary

Name Server Source VRF
1.1.1.1 default
8.8.8.8 default

Name Servers Device Configuration

ip name-server vrf default 1.1.1.1
ip name-server vrf default 8.8.8.8

NTP

NTP Summary

NTP Local Interface

Interface VRF
Management0 default

NTP Servers

Server VRF Preferred Burst iBurst Version Min Poll Max Poll Local-interface Key
time.google.com default - - - - - - - -

NTP Device Configuration

!
ntp local-interface Management0
ntp server time.google.com

Management API HTTP

Management API HTTP Summary

HTTP HTTPS Default Services
False True -

Management API VRF Access

VRF Name IPv4 ACL IPv6 ACL
default - -

Management API HTTP Configuration

!
management api http-commands
   protocol https
   no shutdown
   !
   vrf default
      no shutdown

Authentication

Local Users

Local Users Summary

User Privilege Role
admin 15 network-admin

Local Users Device Configuration

!
username admin privilege 15 role network-admin secret sha512 $6$aKHHd57oXIFPAR8b$P279AwBfC9wE/ZMi5FJZXTrRmM5CUYUFvd7wS9zkBonZAq7qvhZTXumjA0BgWy8RS./3/iGqx4lPXR5kv4Y64.

Monitoring

Spanning Tree

Spanning Tree Summary

STP mode: none

Spanning Tree Device Configuration

!
spanning-tree mode none

Internal VLAN Allocation Policy

Internal VLAN Allocation Policy Summary

Policy Allocation Range Beginning Range Ending
ascending 1006 1199

Internal VLAN Allocation Policy Configuration

!
vlan internal order ascending range 1006 1199

Interfaces

Ethernet Interfaces

Ethernet Interfaces Summary

L2

Interface Description Mode VLANs Native VLAN Trunk Group Channel-Group

*Inherited from Port-Channel Interface

IPv4

Interface Description Type Channel Group IP Address VRF MTU Shutdown ACL In ACL Out
Ethernet1 P2P_LINK_TO_LEAF1_Ethernet1 routed - 172.30.255.0/31 default 1500 false - -
Ethernet2 P2P_LINK_TO_LEAF2_Ethernet1 routed - 172.30.255.2/31 default 1500 false - -

Ethernet Interfaces Device Configuration

!
interface Ethernet1
   description P2P_LINK_TO_LEAF1_Ethernet1
   no shutdown
   mtu 1500
   no switchport
   ip address 172.30.255.0/31
!
interface Ethernet2
   description P2P_LINK_TO_LEAF2_Ethernet1
   no shutdown
   mtu 1500
   no switchport
   ip address 172.30.255.2/31

Loopback Interfaces

Loopback Interfaces Summary

IPv4

Interface Description VRF IP Address
Loopback0 EVPN_Overlay_Peering default 192.0.255.1/32

IPv6

Interface Description VRF IPv6 Address
Loopback0 EVPN_Overlay_Peering default -

Loopback Interfaces Device Configuration

!
interface Loopback0
   description EVPN_Overlay_Peering
   no shutdown
   ip address 192.0.255.1/32

Routing

Service Routing Protocols Model

Multi agent routing protocol model enabled

!
service routing protocols model multi-agent

IP Routing

IP Routing Summary

VRF Routing Enabled
default true
default false

IP Routing Device Configuration

!
ip routing

IPv6 Routing

IPv6 Routing Summary

VRF Routing Enabled
default false
default false

Static Routes

Static Routes Summary

VRF Destination Prefix Next Hop IP Exit interface Administrative Distance Tag Route Name Metric
default 0.0.0.0/0 192.168.0.1 - 1 - - -

Static Routes Device Configuration

!
ip route 0.0.0.0/0 192.168.0.1

Router BGP

Router BGP Summary

BGP AS Router ID
65001 192.0.255.1
BGP Tuning
no bgp default ipv4-unicast
distance bgp 20 200 200
graceful-restart restart-time 300
graceful-restart
maximum-paths 4 ecmp 4

Router BGP Peer Groups

EVPN-OVERLAY-PEERS

Settings Value
Address Family evpn
Next-hop unchanged True
Source Loopback0
BFD True
Ebgp multihop 3
Send community all
Maximum routes 0 (no limit)

IPv4-UNDERLAY-PEERS

Settings Value
Address Family ipv4
Send community all
Maximum routes 12000

BGP Neighbors

Neighbor Remote AS VRF Shutdown Send-community Maximum-routes Allowas-in BFD RIB Pre-Policy Retain
172.30.255.1 65101 default - Inherited from peer group IPv4-UNDERLAY-PEERS Inherited from peer group IPv4-UNDERLAY-PEERS - - -
172.30.255.3 65102 default - Inherited from peer group IPv4-UNDERLAY-PEERS Inherited from peer group IPv4-UNDERLAY-PEERS - - -
192.0.255.3 65101 default - Inherited from peer group EVPN-OVERLAY-PEERS Inherited from peer group EVPN-OVERLAY-PEERS - Inherited from peer group EVPN-OVERLAY-PEERS -
192.0.255.4 65102 default - Inherited from peer group EVPN-OVERLAY-PEERS Inherited from peer group EVPN-OVERLAY-PEERS - Inherited from peer group EVPN-OVERLAY-PEERS -

Router BGP EVPN Address Family

EVPN Peer Groups

Peer Group Activate
EVPN-OVERLAY-PEERS True

Router BGP Device Configuration

!
router bgp 65001
   router-id 192.0.255.1
   no bgp default ipv4-unicast
   distance bgp 20 200 200
   graceful-restart restart-time 300
   graceful-restart
   maximum-paths 4 ecmp 4
   neighbor EVPN-OVERLAY-PEERS peer group
   neighbor EVPN-OVERLAY-PEERS next-hop-unchanged
   neighbor EVPN-OVERLAY-PEERS update-source Loopback0
   neighbor EVPN-OVERLAY-PEERS bfd
   neighbor EVPN-OVERLAY-PEERS ebgp-multihop 3
   neighbor EVPN-OVERLAY-PEERS password 7 q+VNViP5i4rVjW1cxFv2wA==
   neighbor EVPN-OVERLAY-PEERS send-community
   neighbor EVPN-OVERLAY-PEERS maximum-routes 0
   neighbor IPv4-UNDERLAY-PEERS peer group
   neighbor IPv4-UNDERLAY-PEERS password 7 AQQvKeimxJu+uGQ/yYvv9w==
   neighbor IPv4-UNDERLAY-PEERS send-community
   neighbor IPv4-UNDERLAY-PEERS maximum-routes 12000
   neighbor 172.30.255.1 peer group IPv4-UNDERLAY-PEERS
   neighbor 172.30.255.1 remote-as 65101
   neighbor 172.30.255.1 description leaf1_Ethernet1
   neighbor 172.30.255.3 peer group IPv4-UNDERLAY-PEERS
   neighbor 172.30.255.3 remote-as 65102
   neighbor 172.30.255.3 description leaf2_Ethernet1
   neighbor 192.0.255.3 peer group EVPN-OVERLAY-PEERS
   neighbor 192.0.255.3 remote-as 65101
   neighbor 192.0.255.3 description leaf1
   neighbor 192.0.255.4 peer group EVPN-OVERLAY-PEERS
   neighbor 192.0.255.4 remote-as 65102
   neighbor 192.0.255.4 description leaf2
   redistribute connected route-map RM-CONN-2-BGP
   !
   address-family evpn
      neighbor EVPN-OVERLAY-PEERS activate
   !
   address-family ipv4
      no neighbor EVPN-OVERLAY-PEERS activate
      neighbor IPv4-UNDERLAY-PEERS activate

BFD

Router BFD

Router BFD Multihop Summary

Interval Minimum RX Multiplier
1200 1200 3

Router BFD Device Configuration

!
router bfd
   multihop interval 1200 min-rx 1200 multiplier 3

Multicast

Filters

Prefix-lists

Prefix-lists Summary

PL-LOOPBACKS-EVPN-OVERLAY

Sequence Action
10 permit 192.0.255.0/24 eq 32

Prefix-lists Device Configuration

!
ip prefix-list PL-LOOPBACKS-EVPN-OVERLAY
   seq 10 permit 192.0.255.0/24 eq 32

Route-maps

Route-maps Summary

RM-CONN-2-BGP

Sequence Type Match and/or Set
10 permit match ip address prefix-list PL-LOOPBACKS-EVPN-OVERLAY

Route-maps Device Configuration

!
route-map RM-CONN-2-BGP permit 10
   match ip address prefix-list PL-LOOPBACKS-EVPN-OVERLAY

ACL

VRF Instances

VRF Instances Summary

VRF Name IP Routing
default disabled

VRF Instances Device Configuration

Quality Of Service